A-AA+then

CentOS Web Panel สนับสนุนการติดตั้ง PHP หลายเวอร์ชั่นบนเครื่องเดียวกันด้วยครับ โดยที่มีการติดตั้งและใช้งานที่ไม่ยากเลยครับ (แต่ต้องรู้ทริคนิดหน่อย ผมงงมาแล้ว)

หากต้องการติดตั้ง PHP หลายเวอร์ชั่นบนเครื่องเดียวกันแนะนำให้ทำทันทีหลังการติดตั้ง CentOS Web Panel เสร็จครับ เพราะหากไปแก้ไขอะไรก่อนอาจจะทำให้การติดตั้งไม่สำเร็จได้ ซึ่งถ้าพร้อมแล้วให้ดำเนินการตามขั้นตอนด้านล่างได้เลยครับ
  • เลือกเมนู PHP Settings => PHP Selector 
  • เมื่อเข้ามาแล้วคลิก Install Dependencies (1) ก่อนเลยครับ หลังจากนั้น CWP จะทำการติดตั้งโปรแกรมที่จำเป็น ขั้นตอนนี้จะใช้เวลา 10-15 นาทีครับ ถ้าต้องการดูว่ามีอะไรเกิดขึ้นบ้างสามารถดูได้จาก log (จะมีข้อความแจ้ง) หรือใช้คำสั่งนี้
    tail -f /var/log/php-dependencies.log
  • หลังจากนั้นให้ทำตามขั้นตอนที่สอง (2) คือการเลือกเวอร์ชั่นของ PHP ที่จะติดตั้ง ผมเลือกที่จะติดตั้งแค่บางเวอร์ชั่นเท่านั้นครับ โดย PHP 5.4 ไม่จำเป็นต้องเลือก เพราะเป็นเวอร์ชั่นที่ติดตั้งบน Server แล้ว (default)
  • หลังจากเลือกที่พอใจแล้ว ก็คลิก Start Compiler (3) เพิ่มเริ่มติดตั้ง โดยการติดตั้งตัว CWP จะทำการ Compile ทีละเวอร์ชั่นซึ่งอาจจะใช้เวลาถึงเวอร์ชั่นละ 30 นาทีเลยทีเดียว ถ้าเลือกไว้หลายตัวก็นานหน่อยครับ และเช่นกันถ้าต้องการจะดูความคืบหน้าสามารถดูได้ที่
    tail -f /var/log/php-selector-rebuild.log
  • หลังการติดตั้งสำเร็จจะเปลี่ยนเป็นสีเขียวตามรูป เป็นอันเสร็จขั้นตอนการติดตั้ง
การใช้งานก็ง่ายมากครับ สามารถทำได้หลายรูปแบบ เช่น สามารถเลือกให้บางไซต์ใช้ PHP เวอร์ชั่นไหนก็ได้ และยังสามารถเลือกใช้ใน Sub Domain หรือ Sub Directory ได้ด้วย สามารถดูรายละเอียดเต็มๆจากเว็บไซต์ต้นทางได้ที่ http://forum.centos-webpanel.com/php/php-selector/
PHP 4.4
AddHandler application/x-httpd-php44 .php 
PHP 5.2
AddHandler application/x-httpd-php52 .php 
PHP 5.3
AddHandler application/x-httpd-php53 .php 
PHP 5.4
AddHandler application/x-httpd-php54 .php 
PHP 5.6
AddHandler application/x-httpd-php56 .php 
PHP 7
AddHandler application/x-httpd-php7 .php 
วิธีการคือใส่คำสั่งด้านบน (เลือกเพียงรายการเดียว) ลงในไฟล์ .htaccess ในโฟลเดอร์ที่ต้องการได้เลยครับ 
  • ถ้าต้องการให้ทั้งไซต์ใช้ PHP เวอร์ชั่นใดให้ใส่โค้ดด้านบนลงในไฟล์ .htaccess ที่ root ของเว็บไซต์ได้เลย
  • ถ้าต้องการให้บางไดเร็คทอรี่หรือบางซับโดเมน ใช้ PHP ต่างเวอร์ชั่นกันให้ใส่โค้ดลงในไฟล์ .httaccess ที่วางไว้ภายในไดเรคทอรี่นั้นๆเลย
ในกรณีที่มีการกระทำใดๆไปก่อนหน้าแล้ว และทำให้ไม่สามารถติดตั้งได้ ผมแนะนำให้ลองทำตามขั้นตอนต่อไปนี้ดูนะครับ
  • ให้กลับไปเลือก PHP Version Switcher เป็นเวอร์ชั่น 5.4 ซึ่งเป็นเวอร์ชั่นที่มากับเครื่องตอนติดตั้ง
  • ไม่ต้องเลือกติดตั้ง PHP 5.4 ตอนติดตั้ง PHP Selector
  • ถ้าไม่แน่ใจ ให้กด Reset Flags ก่อนการติดตั้ง

Relate

^